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Walkthrough / Take Home Exercise

Blue Text: CAT/ENVI interface instructions
Green Text: Filename of source data for accompanying figure

The intermediate data processing products, derived data products, and 
ancillary files presented here are available online:

PDS Geosciences Node: http://pds-geosciences.wustl.edu/workshops/
CRISM SOC: http://crism.jhuapl.edu/CRISM_workshop_2009/

Participants in the CRISM Data Users' Workshop are encouraged to replicate 
the data processing and analysis presented here as a hands-on exercise

http://pds-geosciences.wustl.edu/workshops/
http://crism.jhuapl.edu/CRISM_workshop_2009/
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Example CRISM Observation: FRT000064D9

IR RGB
R: 2.53 μm
G: 1.51 μm
B: 1.08 μm

VNIR RGB
R: 0.71 μm
G: 0.60 μm
B: 0.53 μm
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CRISM Data Processing Work Flow

• Typical CRISM data processing work flow (CAT functionality):

– CAT: PDS to CAT conversion

– PHT: Photometric correction [COS(i)]

– ATM: Volcano Scan atmospheric correction (IR)

– CLN: CIRRUS (CRISM Clean)

• Destripe (VNIR and IR)

• Despike (IR)

– SUM: Summary parameter calculation

CAT PHT ATM CLN SUM
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IR Progression: PDS to CAT

 FRT000064D9_07_IF166L_TRR2_CAT.IMG FRT000064D9_07_IF166L_TRR2.IMG

ENVI → CAT → Convert Format: PDS to CAT

CAT PHT ATM CLN SUM

Reverses Spectral Dimension
Applies Default Bad Bands



03/22/2009 CRISM Workshop - Data Processing Walkthrough FPS - 6

Photometric Correction  [COS(i)] 

 FRT000064D9_07_IF166L_TRR2_CAT_PHT.IMG FRT000064D9_07_IF166L_TRR2_CAT.IMG

ENVI → CAT → ATP Corrections → [Select File] → Photometric correction: Division by cos(i):

CAT PHT ATM CLN SUM
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Atmospheric Correction [Volcano Scan]

 FRT000064D9_07_IF166L_TRR2_CAT_PHT.IMG  FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM.IMG

CAT PHT ATM CLN SUM

ENVI → CAT → ATP Corrections → [Select File] → Division by scaled volcano observation
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CIRRUS [CRISM Clean] 

 FRT000064D9_07_IF166L_TRR2...
_CAT_PHT_ATM.IMG

CAT PHT ATM CLN SUM

ENVI → CAT → Data Filtering → CIRRUS → Clean Spectral Cube
Select both destripe and despike for IR data

 FRT000064D9_07_IF166L_TRR2...
_CAT_PHT_ATM_DST_DSP.IMG
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IR Spectral Summary Parameters

CAT PHT ATM CLN SUM

IRA (Infrared Albedo Proxy) D2300 (2300 nm Drop-Off)

LCPINDEX (Low-Calcium 
Pyroxene Index)

ISLOPE1 (1800 nm to 
2500 nm Inverse 
Spectral Slope)

FRT000064D9_07_IF166L_TRR2...
_CAT_PHT_ATM_DST_DSP_SUM.IMG

ENVI → CAT → Spectral Analysis Utilities → Spectral Summary Products → IR Data
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VNIR Progression: PDS to CAT

CAT PHT CLN SUM

ENVI → CAT → Convert Format: PDS to CAT

FRT000064D9_07_IF166S_TRR2.IMG FRT000064D9_07_IF166S_TRR2_CAT.IMG

Applies Default Bad Bands
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Photometric Correction  [COS(i)] 

CAT PHT CLN SUM

ENVI → CAT → ATP Corrections → [Select File] → Photometric correction: Division by cos(i):

FRT000064D9_07_IF166S_TRR2_CAT_PHT.IMGFRT000064D9_07_IF166S_TRR2_CAT.IMG
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CIRRUS [CRISM Clean] 

CAT PHT CLN SUM

ENVI → CAT → Data Filtering → CIRRUS → Clean Spectral Cube
Select destripe for VNIR data

FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST.IMGFRT000064D9_07_IF166S_TRR2_CAT_PHT.IMG
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VNIR Spectral Summary Parameters

R770 (I/F @ 770 nm)

RBR (Red/Blue Ratio)

RPEAK (Wavelength of VNIR 
Reflectance Maximum)

BD530 (Band Depth 
@ 530 nm)CAT PHT CLN SUM

ENVI → CAT → Spectral Analysis Utilities → Spectral Summary Products → VNIR Data

FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST.IMG
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CRISM Data Analysis Work Flow

• Typical CRISM data analysis work flow (ENVI functionality):

– Spectral unit identification

• Guided spectral investigation

• Link spectral data and selected spectral summary parameter(s)

– Spectral extraction

• Create ROIs based on linked information sources

– Spectral ratios

– Spectral library comparison
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Spectral Unit Identification: D2300

Image → Tools → Link → Link Displays... 
Select displays for pixel coordinate link
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Pixel coordinate link must be done with common-detector data
VNIR/IR geographic link available after map projection
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ROIs and Mean Spectra: D2300

ROI file: FRT000064D9_D2300.roi

Image → Overlay → Region of Interest... 
Construct ROIs from spectral parameter thresholds; manual specification; ROI intersection

ROI Tool → Select target ROI → Stats
Compute spectral stats for spatial pixels in ROI Selecting target and reference ROIs from common 

columns will mitigate spectral smile effects in the ratio
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Ratio Spectrum and Library Comparison: D2300

ENVI → Spectral → Spectral Math
Enter spectral math expression e.g. s1/s2
Map variables to spectra in ENVI session

ENVI → Spectral → Spectral Libraries → Spectral Library Viewer
CRISM phyllosilicate spectral library

SLI file: FRT000064D9_D2300.sli

Smectite PHY07_02    [Link to Spectral Library]
Smectite PHY07    [Link to Spectral Library]

http://pds-geosciences.wustl.edu/MROCRISMSpectralLibrary/resultsdisplay.aspx?sample=PHY07&analysis=PHY07_2&segments=2
http://pds-geosciences.wustl.edu/MROCRISMSpectralLibrary/resultsdisplay.aspx?sample=PHY07&analysis=PHY07&segments=2
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Spectral Unit Identification: LCPINDEX
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Image → Tools → Link → Link Displays... 
Select displays for pixel coordinate link
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ROIs and Mean Spectra: LCPINDEX

ROI file: FRT000064D9_LCPINDEX.roiROI Tool → Select target ROI → Stats
Compute spectral stats for spatial pixels in ROI

Image → Overlay → Region of Interest... 
Construct ROIs from spectral parameter thresholds; manual specification; ROI intersection
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Ratio Spectrum and Library Comparison: LCPINDEX

SLI file:FRT000064D9_LCPINDEX.sli

ENVI → Spectral → Spectral Math
Enter spectral math expression e.g. s1/s2
Map variables to spectra in ENVI session

ENVI → Spectral → Spectral Libraries → Spectral Library Viewer
CRISM phyllosilicate spectral library

Orthopyroxene CASB51    [Link to Spectral Library]

http://pds-geosciences.wustl.edu/MROCRISMSpectralLibrary/resultsdisplay.aspx?sample=Orthopyroxene&analysis=CASB51&segments=1
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CRISM Data Registration

• Typical CRISM georeferencing procedure  (CAT/ENVI functionality):

– Project single cube (CAT)

• MRO standard projection at native observation nadir resolution

– Project multiple cubes to a common reference (ENVI GLT)

• CAT or user supplied projection information

• VNIR/IR data from common observation for layer stacking

• Data from different observations for mosaicking

– Layer stacking and/or mosaicking (ENVI)



03/22/2009 CRISM Workshop - Data Processing Walkthrough FPS - 22

CAT Map Projection

IR: 18.6 m/pxl VNIR: 18.9 m/pxl

ENVI → CAT → Map Utilities → Project Single Cube Data Projects CRISM data to MRO standard using native nadir resolution

FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST_PRJ.IMG

FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST_DSP_PRJ.IMG
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Custom Map Projection: Build GLT

ENVI → Map → Georeference from Input Geometry → Build GLT
Input X Geometry Band: CRISM DDR Band 5 (Longitude, areocentric, deg E)
Input Y Geometry Band: CRISM DDR Band 4 (Latitude, areocentric, deg N)
Input Projection: Geographic Lat/Lon
Output Projection: User Defined or Mars Default (MRO)
Output Pixel Size: User Defined – Default is native image resolution

Set to consistent value for mosiacking or layer stacking
Output Rotation: User Defined – 0 recommended in most cases

GLT: Geographic Lookup Table – 
A map of pixel locations relating one 
frame of reference to another

  
FRT000064D9_07_DE166L_DDR1_GLT.IMG

GLT Sample Lookup
20.0 m/pxl

GLT Line Lookup
20.0 m/pxl
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Custom Map Projection: Apply GLT

ENVI → Map → Georeference from Input Geometry → Georeference from GLT
Input Geometry Lookup File: Select GLT file
Input Data File: Select data file to project
Background Value: 65535 is CRISM NULL value

ENVI → Map → Georeference from IGM 
Cascades construction and application 
of GLT from DDR lat/lon information

IR: 20.0 m/pxl VNIR: 20.0 m/pxl

FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST_REF.IMG

FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST_DSP_REF.IMG
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`

CRISM VNIR/IR Layer Stacking

ENVI → Basic Tools → Layer Stacking 
Select input layers (files) and output projection

FRT000064D9_07_IF166SL_TRR2_LST.IMG

FRT000064D9_07_IF166SL_TRR2_LST_RAT.IMG

1330 nm I/F

770 nm I/F

IR/VNIR Ratio

D2300 Type Location

LCPINDEX Type Location

BD530 Type Location
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Additional Slides
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Walkthrough File List (1/2)

VNIR IMG files:
FRT000064D9_07_IF166S_TRR2.IMG CRISM TRR2 PDS IMG file
FRT000064D9_07_DE166S_DDR1.IMG CRISM DDR1 PDS IMG file

FRT000064D9_07_IF166S_TRR2_CAT.IMG CAT (ENVI) format CRISM IMG data file
FRT000064D9_07_IF166S_TRR2_CAT_PHT.IMG Photometrically corrected version of the above
FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST.IMG Destriped version of the above
FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST_SUM.IMG Spectral summary parameter cube calculated from the above

FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST_PRJ.IMG Map projected version of the processed spectral data
FRT000064D9_07_DE166S_DDR1_GLT.IMG Custom geographic lookup table derived from the CRISM DDR
FRT000064D9_07_IF166S_TRR2_CAT_PHT_DST_REF.IMG Custom map projected version of the processed spectral data

IR IMG files:
FRT000064D9_07_IF166L_TRR2.IMG CRISM TRR2 PDS IMG file
FRT000064D9_07_DE166L_DDR1.IMG CRISM DDR1 PDS IMG file

FRT000064D9_07_IF166L_TRR2_CAT.IMG CAT (ENVI) format CRISM IMG data file
FRT000064D9_07_IF166L_TRR2_CAT_PHT.IMG Photometrically corrected version of the above
FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM.IMG Atmospherically corrected version of the above
FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST.IMG Destriped version of the above
FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST_DSP.IMG Despiked version of the above
FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST_DSP_SUM.IMG Spectral summary parameter cube calculated from the above

FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST_DSP_PRJ.IMG Map projected version of the processed spectral data
FRT000064D9_07_DE166L_DDR1_GLT.IMG Custom geographic lookup table derived from the CRISM DDR
FRT000064D9_07_IF166L_TRR2_CAT_PHT_ATM_DST_DSP_REF.IMG Custom map projected version of the processed spectral data

CRISM PDS IMG files have accompanying label (LBL) files
CAT/ENVI IMG files have accompanying header (HDR) files
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Walkthrough File List (2/2)

VNIR + IR IMG files:
FRT000064D9_07_IF166SL_TRR2_LST.IMG Merged CRISM VNIR and IR processed spectral data 
FRT000064D9_07_IF166SL_TRR2_LST_RAT.IMG IR/VNIR merged ratio parameter

Ancillary files:
FRT000064D9_D2300.roi Region of interest file for D2300 spectral investigation
FRT000064D9_LCPINDEX.roi Region of interest file for LCPINDEX spectral investigation

FRT000064D9_D2300.sli Spectral library file for D2300 spectral investigation
FRT000064D9_LCPINDEX.sli Spectral library file for LCPINDEX spectral investigation

FRT000064D9_D2300.sta Spectral statistics for D2300 target ROI
FRT000064D9_D2300_reference.sta Spectral statistics for D2300 reference ROI
FRT000064D9_LCPINDEX.sta Spectral statistics for LCPINDEX target ROI
FRT000064D9_LCPINDEX_reference.sta Spectral statistics for LCPINDEX reference ROI

FRT000064D9_07_IF166L_TRR2.ann Annotation file for map projected images
FRT000064D9_07_IF166L_TRR2.grd Grid definition file for map projected images

ENVI spectral library files have accompanying header (HDR) files
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CRISM TRR3 Data Filtering Preview

 FRT000064D9_07_IF166L_TRR2.IMG  FRT000064D9_07_IF166L_TRR2_IKF.IMG
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